Author Topic: Can't get past the intro  (Read 2004 times)

maxxbanana

  • Probably not a Spambot
  • *
  • Posts: 5
  • Karma: +1/-0
    • View Profile
Can't get past the intro
« on: June 13, 2015, 09:41:49 PM »
So the game runs after being started, i can make a character but after the intro the game crashes at a black screen. i have the full version off of steam. it used to run great til i forget what update, but i think it may have been the 0.1.11.0 update.

stats: windows 7 home premium, r9 270x (amd) gpu, fx-6120 (amd) 6 core cpu.

« Last Edit: June 14, 2015, 03:12:31 PM by maxxbanana »

epeli

  • Wiki Administrator
  • Godman
  • ***
  • Posts: 1443
  • Karma: +103/-0
    • View Profile
Re: Can't get past the intro
« Reply #1 on: June 19, 2015, 09:20:57 AM »
Uh. I haven't got a clue what could be wrong. Does it always crash with a black screen when you load a game or start playing, or is it only when you start a new game?

Try verifying integrity of game cache through Steam if you haven't already done so. Also, have you tried running the game without Steam? (Close Steam completely, navigate to the game's folder and run underrail.exe)

You probably have the required redistributables (XNA 4.0 refresh and .NET 4.0 or newer) installed since the game starts, but you could also try repairing them. You can find their installers in the game's _CommonRedist folder.
[[Underrail Wiki]] // character build tool: underrail.info.tm (thread)

maxxbanana

  • Probably not a Spambot
  • *
  • Posts: 5
  • Karma: +1/-0
    • View Profile
Re: Can't get past the intro
« Reply #2 on: June 23, 2015, 02:39:14 AM »
I have verified game cache, reinstalled, played with steam off, and have repaired the redistributables. yes it is when a new starts. Maybe since the one update the zone transition error occurred, follow by a wiped save (or i deleted it i don't recall, sorry). thank you for the help.

note: even before when i first bought the game my computer wouldn't run it i believe because of the processor, it wouldn't be the first game its screwed up.
« Last Edit: June 23, 2015, 02:46:45 AM by maxxbanana »

epeli

  • Wiki Administrator
  • Godman
  • ***
  • Posts: 1443
  • Karma: +103/-0
    • View Profile
Re: Can't get past the intro
« Reply #3 on: June 23, 2015, 10:52:20 AM »
Hmm. Does the crash write to any error logs in your Documents\My Games\Underrail folder?

The CPU thing sounds a bit strange. I know the FX/Opteron series can have performance problems (and there's a fix for that, https://support.microsoft.com/en-us/kb/2645594) but it shouldn't affect Underrail.
[[Underrail Wiki]] // character build tool: underrail.info.tm (thread)

epeli

  • Wiki Administrator
  • Godman
  • ***
  • Posts: 1443
  • Karma: +103/-0
    • View Profile
Re: Can't get past the intro
« Reply #4 on: June 24, 2015, 11:16:27 AM »
That error log seems to indicate something's wrong with your .NET installation, but the log is over a year old. Do you still get the same error or no new logs at all?

If you're still getting the same error, you could try uninstalling any versions of .NET 4 you have and then reinstalling only the latest one: https://www.microsoft.com/en-us/download/details.aspx?id=42643
[[Underrail Wiki]] // character build tool: underrail.info.tm (thread)

maxxbanana

  • Probably not a Spambot
  • *
  • Posts: 5
  • Karma: +1/-0
    • View Profile
Re: Can't get past the intro
« Reply #5 on: June 24, 2015, 09:18:26 PM »
sorry here is a current one

System.Exception: Failed to save game 'autosave'. Exception: System.IO.Compression.ZLibException: The underlying compression routine could not be loaded correctly. ---> System.TypeInitializationException: The type initializer for 'NativeZLibDLLStub' threw an exception. ---> System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
   at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
   at System.Runtime.InteropServices.Marshal.ThrowExceptionForHR(Int32 errorCode, IntPtr errorInfo)
   at System.IO.Compression.ZLibNative.ZLibStreamHandle.NativeZLibDLLStub.LoadZLibDLL()
   at System.IO.Compression.ZLibNative.ZLibStreamHandle.NativeZLibDLLStub..cctor()
   --- End of inner exception stack trace ---
   at System.IO.Compression.ZLibNative.ZLibStreamHandle.DeflateInit2_(CompressionLevel level, Int32 windowBits, Int32 memLevel, CompressionStrategy strategy)
   at System.IO.Compression.DeflaterZLib.DeflateInit(CompressionLevel compressionLevel, Int32 windowBits, Int32 memLevel, CompressionStrategy strategy)
   --- End of inner exception stack trace ---
   at System.IO.Compression.DeflaterZLib.DeflateInit(CompressionLevel compressionLevel, Int32 windowBits, Int32 memLevel, CompressionStrategy strategy)
   at System.IO.Compression.DeflaterZLib..ctor(CompressionLevel compressionLevel)
   at System.IO.Compression.DeflateStream.CreateDeflater(Nullable`1 compressionLevel)
   at System.IO.Compression.DeflateStream..ctor(Stream stream, CompressionMode mode, Boolean leaveOpen)
   at System.IO.Compression.GZipStream..ctor(Stream stream, CompressionMode mode)
   at byw.SerializeToBinaryFileCompressed[T](String filePath, T obj, SerializationBinder binder, Int64 currentDataModelVersion, Boolean embedDataModelVersion)
   at ash.b(String A_0)
   at a7e.b(String A_0, Boolean A_1)
   at a7e.abz(String A_0, Boolean A_1, Boolean A_2) ---> System.IO.Compression.ZLibException: The underlying compression routine could not be loaded correctly. ---> System.TypeInitializationException: The type initializer for 'NativeZLibDLLStub' threw an exception. ---> System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
   at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
   at System.Runtime.InteropServices.Marshal.ThrowExceptionForHR(Int32 errorCode, IntPtr errorInfo)
   at System.IO.Compression.ZLibNative.ZLibStreamHandle.NativeZLibDLLStub.LoadZLibDLL()
   at System.IO.Compression.ZLibNative.ZLibStreamHandle.NativeZLibDLLStub..cctor()
   --- End of inner exception stack trace ---
   at System.IO.Compression.ZLibNative.ZLibStreamHandle.DeflateInit2_(CompressionLevel level, Int32 windowBits, Int32 memLevel, CompressionStrategy strategy)
   at System.IO.Compression.DeflaterZLib.DeflateInit(CompressionLevel compressionLevel, Int32 windowBits, Int32 memLevel, CompressionStrategy strategy)
   --- End of inner exception stack trace ---
   at System.IO.Compression.DeflaterZLib.DeflateInit(CompressionLevel compressionLevel, Int32 windowBits, Int32 memLevel, CompressionStrategy strategy)
   at System.IO.Compression.DeflaterZLib..ctor(CompressionLevel compressionLevel)
   at System.IO.Compression.DeflateStream.CreateDeflater(Nullable`1 compressionLevel)
   at System.IO.Compression.DeflateStream..ctor(Stream stream, CompressionMode mode, Boolean leaveOpen)
   at System.IO.Compression.GZipStream..ctor(Stream stream, CompressionMode mode)
   at byw.SerializeToBinaryFileCompressed[T](String filePath, T obj, SerializationBinder binder, Int64 currentDataModelVersion, Boolean embedDataModelVersion)
   at ash.b(String A_0)
   at a7e.b(String A_0, Boolean A_1)
   at a7e.abz(String A_0, Boolean A_1, Boolean A_2)
   --- End of inner exception stack trace ---
   at b4d.LogAndThrow[T](Exception innerException, LogSeverity severity, String message, Object[] messageArgs)
   at a7e.abz(String A_0, Boolean A_1, Boolean A_2)
   at lj.cw(af8 A_0)
   at wv.e(af8 A_0)
   at a4j.cw(af8 A_0)
   at wv.e(af8 A_0)

epeli

  • Wiki Administrator
  • Godman
  • ***
  • Posts: 1443
  • Karma: +103/-0
    • View Profile
Re: Can't get past the intro
« Reply #6 on: June 25, 2015, 09:55:33 AM »
It's still the exact same error, although triggered at a different point.
Exception: System.IO.Compression.ZLibException: The underlying compression routine could not be loaded correctly ---> System.TypeInitializationException: The type initializer for 'NativeZLibDLLStub' threw an exception. ---> System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

Basically, the problem is in your .NET installation, not Underrail. If repairing it didn't help, you could try uninstalling and reinstalling.
[[Underrail Wiki]] // character build tool: underrail.info.tm (thread)